Finalize and Sign experiencing long load times

Incident Report for LinkSquares Status Page

Resolved

This incident has been resolved.
Posted Jul 02, 2025 - 22:27 UTC

Monitoring

Performance has returned to normal. We are actively monitoring the situation to ensure performance remains stable
Posted Jul 01, 2025 - 21:09 UTC

Investigating

Users may experience longer-than-expected load times in Finalize and Sign. We are working to restore application performance as soon as possible.
Posted Jul 01, 2025 - 20:53 UTC
This incident affected: Finalize.